using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0]*([1][1][0|2|5])|([1][1][6]\d{3})|([1][1][8][1-9]{2})";
string input = @"110
112
115
19222
116117
116116
11800
11811
11823
118222
11899
1234
9987
1120
112554443";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}