package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0]*([1][1][0|2|5])|([1][1][6]\d{3})|([1][1][8][1-9]{2})`)
var str = `110
112
115
19222
116117
116116
11800
11811
11823
118222
11899
1234
9987
1120
112554443`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}