$re = '/^[0]*([1][1][0|2|5])|([1][1][6]\d{3})|([1][1][8][1-9]{2})/m';
$str = '110
112
115
19222
116117
116116
11800
11811
11823
118222
11899
1234
9987
1120
112554443';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);