use strict;
my $str = '110
112
115
19222
116117
116116
11800
11811
11823
118222
11899
1234
9987
1120
112554443';
my $regex = qr/^[0]*([1][1][0|2|5])|([1][1][6]\d{3})|([1][1][8][1-9]{2})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}