re = /<!--{if(\s+\(?(\$[^\s!=><}]+)[^}]+)}-->/m
str = '<!--{if $projectdisplaymode != \'Widget\'}-->
<!--{if (isset($projectdisplaymode ) && $projectdisplaymode != \'Widget\' )}-->
<!--{if $runnow == \'true\'}-->
<!--{if (isset($runnow ) && $runnow == \'true\' )}-->
<!--{if $showdelete == \'Yes\'}-->
<!--{if $average_rating_colorclass == \'progress0\'}-->
<!--{if ($percentage!="")}-->
--Find: <!--{if(\\s+\\(?(\\$[^\\s!=><}]+)[^}]+)}-->
--Replace: <!--{if (isset($2) && $1)}-->'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end