#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<!--{if(\s+\(?(\$[^\s!=><}]+)[^}]+)}-->"
Local $sString = "<!--{if $projectdisplaymode != 'Widget'}-->" & @CRLF & _
"<!--{if (isset($projectdisplaymode ) && $projectdisplaymode != 'Widget' )}-->" & @CRLF & _
"<!--{if $runnow == 'true'}-->" & @CRLF & _
"<!--{if (isset($runnow ) && $runnow == 'true' )}-->" & @CRLF & _
"<!--{if $showdelete == 'Yes'}-->" & @CRLF & _
"<!--{if $average_rating_colorclass == 'progress0'}-->" & @CRLF & _
"<!--{if ($percentage!="")}-->" & @CRLF & _
"" & @CRLF & _
"--Find: <!--{if(\s+\(?(\$[^\s!=><}]+)[^}]+)}-->" & @CRLF & _
"--Replace: <!--{if (isset($2) && $1)}-->"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")