import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!--\\{if(\\s+\\(?(\\$[^\\s!=><\\}]+)[^\\}]+)\\}-->";
final String string = "<!--{if $projectdisplaymode != 'Widget'}-->\n"
+ "<!--{if (isset($projectdisplaymode ) && $projectdisplaymode != 'Widget' )}-->\n"
+ "<!--{if $runnow == 'true'}-->\n"
+ "<!--{if (isset($runnow ) && $runnow == 'true' )}-->\n"
+ "<!--{if $showdelete == 'Yes'}-->\n"
+ "<!--{if $average_rating_colorclass == 'progress0'}-->\n"
+ "<!--{if ($percentage!=\"\")}-->\n\n"
+ "--Find: <!--{if(\\s+\\(?(\\$[^\\s!=><}]+)[^}]+)}-->\n"
+ "--Replace: <!--{if (isset($2) && $1)}-->";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}