const regex = /<!--{if(\s+\(?(\$[^\s!=><}]+)[^}]+)}-->/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<!--{if(\\s+\\(?(\\$[^\\s!=><}]+)[^}]+)}-->', 'gm')
const str = `<!--{if \$projectdisplaymode != 'Widget'}-->
<!--{if (isset(\$projectdisplaymode ) && \$projectdisplaymode != 'Widget' )}-->
<!--{if \$runnow == 'true'}-->
<!--{if (isset(\$runnow ) && \$runnow == 'true' )}-->
<!--{if \$showdelete == 'Yes'}-->
<!--{if \$average_rating_colorclass == 'progress0'}-->
<!--{if (\$percentage!="")}-->
--Find: <!--{if(\\s+\\(?(\\\$[^\\s!=><}]+)[^}]+)}-->
--Replace: <!--{if (isset(\$2) && \$1)}-->`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}