using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<!--{if(\s+\(?(\$[^\s!=><}]+)[^}]+)}-->";
string input = @"<!--{if $projectdisplaymode != 'Widget'}-->
<!--{if (isset($projectdisplaymode ) && $projectdisplaymode != 'Widget' )}-->
<!--{if $runnow == 'true'}-->
<!--{if (isset($runnow ) && $runnow == 'true' )}-->
<!--{if $showdelete == 'Yes'}-->
<!--{if $average_rating_colorclass == 'progress0'}-->
<!--{if ($percentage!="")}-->
--Find: <!--{if(\s+\(?(\$[^\s!=><}]+)[^}]+)}-->
--Replace: <!--{if (isset($2) && $1)}-->";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}