// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^0[0-9]{2}\*{6}[0-9]{2}$").unwrap();
let string = "# Test data
# Corrects
079******56
# Errors
079*****56
079*******56
079**-****56
79******56
709******56
0793*****56
079*****456
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}