package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^0[0-9]{2}\*{6}[0-9]{2}$`)
var str = `# Test data
# Corrects
079******56
# Errors
079*****56
079*******56
079**-****56
79******56
709******56
0793*****56
079*****456
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}