$re = '/^0[0-9]{2}\*{6}[0-9]{2}$/m';
$str = '# Test data
# Corrects
079******56
# Errors
079*****56
079*******56
079**-****56
79******56
709******56
0793*****56
079*****456
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);