import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^0[0-9]{2}\\*{6}[0-9]{2}$";
final String string = "# Test data\n"
+ "# Corrects\n"
+ "079******56\n\n"
+ "# Errors\n"
+ "079*****56\n"
+ "079*******56\n"
+ "079**-****56\n"
+ "79******56\n"
+ "709******56\n"
+ "0793*****56\n"
+ "079*****456\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}