using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^0[0-9]{2}\*{6}[0-9]{2}$";
string input = @"# Test data
# Corrects
079******56
# Errors
079*****56
079*******56
079**-****56
79******56
709******56
0793*****56
079*****456
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}