import Foundation
let pattern = #"^(?:(?!(?:not allowed|filter|mirc)).)*?(?:http:\/\/|www\.|porn|credit card)(?:(?!(?:not allowed|filter|mirc)).)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
http://porn.filter
http://porn.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)