const regex = /^(?:(?!(?:not allowed|filter|mirc)).)*?(?:http:\/\/|www\.|porn|credit card)(?:(?!(?:not allowed|filter|mirc)).)*$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?!(?:not allowed|filter|mirc)).)*?(?:http:\\\/\\\/|www\\.|porn|credit card)(?:(?!(?:not allowed|filter|mirc)).)*$', 'gim')
const str = `http://porn.filter
http://porn.com
`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);