re = /^(?:(?!(?:not allowed|filter|mirc)).)*?(?:http:\/\/|www\.|porn|credit card)(?:(?!(?:not allowed|filter|mirc)).)*$/im
str = 'http://porn.filter
http://porn.com
'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result