# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:(?!(?:not allowed|filter|mirc)).)*?(?:http:\\/\\/|www\.|porn|credit card)(?:(?!(?:not allowed|filter|mirc)).)*$/-/gim;t' <<< "http://porn.filter
http://porn.com
"