#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)^(?:(?!(?:not allowed|filter|mirc)).)*?(?:http:\/\/|www\.|porn|credit card)(?:(?!(?:not allowed|filter|mirc)).)*$"
Local $sString = "http://porn.filter" & @CRLF & _
"http://porn.com" & @CRLF & _
""
Local $sSubst = "-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)