// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)звук ([Гг]ав!|[Мм]яу!)").unwrap();
let string = "звук мяу!
звук Мяу!
звук гав!
звук Гав!
";
let substitution = "Если улышал \\0 Скажи в ответ: \\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}