# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/звук ([Гг]ав!|[Мм]яу!)/Если улышал \0 Скажи в ответ: \1/gm;t' <<< "звук мяу!
звук Мяу!
звук гав!
звук Гав!
"