$re = '/звук ([Гг]ав!|[Мм]яу!)/m';
$str = 'звук мяу!
звук Мяу!
звук гав!
звук Гав!
';
$subst = "Если улышал \0 Скажи в ответ: \1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;