const regex = /звук ([Гг]ав!|[Мм]яу!)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('звук ([Гг]ав!|[Мм]яу!)', 'gm')
const str = `звук мяу!
звук Мяу!
звук гав!
звук Гав!
`;
const subst = `Если улышал \0 Скажи в ответ: \1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);