re = /звук ([Гг]ав!|[Мм]яу!)/m
str = 'звук мяу!
звук Мяу!
звук гав!
звук Гав!
'
subst = 'Если улышал \\0 Скажи в ответ: \\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result