re = /"service"\s*:\s*{\s*"healthy"\s*:\s*true/
str = '{
"service": {
"healthy": true
},
"cassandra_connection" : {
"healthy" : true
},
"deadlocks" : {
"healthy" : true
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end