#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""service"\s*:\s*{\s*"healthy"\s*:\s*true"
Local $sString = "{" & @CRLF & _
" "service": {" & @CRLF & _
" "healthy": true" & @CRLF & _
" }," & @CRLF & _
" "cassandra_connection" : {" & @CRLF & _
" "healthy" : true" & @CRLF & _
" }," & @CRLF & _
" "deadlocks" : {" & @CRLF & _
" "healthy" : true" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")