package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"service"\s*:\s*{\s*"healthy"\s*:\s*true`)
var str = `{
"service": {
"healthy": true
},
"cassandra_connection" : {
"healthy" : true
},
"deadlocks" : {
"healthy" : true
}
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}