using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""service""\s*:\s*{\s*""healthy""\s*:\s*true";
string input = @"{
""service"": {
""healthy"": true
},
""cassandra_connection"" : {
""healthy"" : true
},
""deadlocks"" : {
""healthy"" : true
}
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}