import Foundation
let pattern = ##"^([^#].*)?^\s*dev1"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
#| Environment | Port-prefix | Subnet | Target-host |
#dev1 300 8 ibdock2
# dev1 300 8 ibdock2
#dev1 300 8 ibdock2
# dev1 300 8 ibdock2
dev1 300 8 ibdock2
dev1 300 8 ibdock2
dev 301 1 ibdock2
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)