#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([^#].*)?^\s*dev1"
Local $sString = "#| Environment | Port-prefix | Subnet | Target-host |" & @CRLF & _
"#dev1 300 8 ibdock2" & @CRLF & _
"# dev1 300 8 ibdock2" & @CRLF & _
" #dev1 300 8 ibdock2" & @CRLF & _
" # dev1 300 8 ibdock2" & @CRLF & _
"dev1 300 8 ibdock2" & @CRLF & _
" dev1 300 8 ibdock2" & @CRLF & _
"dev 301 1 ibdock2" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)