$re = '/^([^#].*)?^\s*dev1/m';
$str = '#| Environment | Port-prefix | Subnet | Target-host |
#dev1 300 8 ibdock2
# dev1 300 8 ibdock2
#dev1 300 8 ibdock2
# dev1 300 8 ibdock2
dev1 300 8 ibdock2
dev1 300 8 ibdock2
dev 301 1 ibdock2
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;