# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^#].*)?^\s*dev1//gm;t' <<< "#| Environment | Port-prefix | Subnet | Target-host |
#dev1 300 8 ibdock2
# dev1 300 8 ibdock2
#dev1 300 8 ibdock2
# dev1 300 8 ibdock2
dev1 300 8 ibdock2
dev1 300 8 ibdock2
dev 301 1 ibdock2
"