const regex = /^([^#].*)?^\s*dev1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^#].*)?^\\s*dev1', 'gm')
const str = `#| Environment | Port-prefix | Subnet | Target-host |
#dev1 300 8 ibdock2
# dev1 300 8 ibdock2
#dev1 300 8 ibdock2
# dev1 300 8 ibdock2
dev1 300 8 ibdock2
dev1 300 8 ibdock2
dev 301 1 ibdock2
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);