$re = '/^(\+98?)?{?(0?9[0-9]{9,9}}?)$/m';
$str = '09036565656
09151251685
09337729292
09136565655
09125151515
+989151251685
+9809151251688
09124527844
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);