using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\+98?)?{?(0?9[0-9]{9,9}}?)$";
string input = @"09036565656
09151251685
09337729292
09136565655
09125151515
+989151251685
+9809151251688
09124527844
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}