package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\+98?)?{?(0?9[0-9]{9,9}}?)$`)
var str = `09036565656
09151251685
09337729292
09136565655
09125151515
+989151251685
+9809151251688
09124527844
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}