const regex = /^(\+98?)?{?(0?9[0-9]{9,9}}?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+98?)?{?(0?9[0-9]{9,9}}?)$', 'gm')
const str = `09036565656
09151251685
09337729292
09136565655
09125151515
+989151251685
+9809151251688
09124527844
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}