use strict;
my $str = '09036565656
09151251685
09337729292
09136565655
09125151515
+989151251685
+9809151251688
09124527844
';
my $regex = qr/^(\+98?)?{?(0?9[0-9]{9,9}}?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}