$re = '/v6\/[0-9]{3}[a-z]?\/(?!(elodie|bacchus|sophie)).*$/m';
$str = 'v6/429/elodie
v6/429/bacchus
v6/429/Bacchus
v6/429/Bac chus
v6/429/truc
v6/429/sophie';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);