using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"v6\/[0-9]{3}[a-z]?\/(?!(elodie|bacchus|sophie)).*$";
string input = @"v6/429/elodie
v6/429/bacchus
v6/429/Bacchus
v6/429/Bac chus
v6/429/truc
v6/429/sophie";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}