import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "v6\\/[0-9]{3}[a-z]?\\/(?!(elodie|bacchus|sophie)).*$";
final String string = "v6/429/elodie\n"
+ "v6/429/bacchus\n"
+ "v6/429/Bacchus\n"
+ "v6/429/Bac chus\n"
+ "v6/429/truc\n"
+ "v6/429/sophie";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}