use strict;
my $str = 'v6/429/elodie
v6/429/bacchus
v6/429/Bacchus
v6/429/Bac chus
v6/429/truc
v6/429/sophie';
my $regex = qr/v6\/[0-9]{3}[a-z]?\/(?!(elodie|bacchus|sophie)).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}