#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)v6\/[0-9]{3}[a-z]?\/(?!(elodie|bacchus|sophie)).*$"
Local $sString = "v6/429/elodie" & @CRLF & _
"v6/429/bacchus" & @CRLF & _
"v6/429/Bacchus" & @CRLF & _
"v6/429/Bac chus" & @CRLF & _
"v6/429/truc" & @CRLF & _
"v6/429/sophie"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")