import Foundation
let pattern = #"(\x1B7)?(\x9B|\x1B\[)[0-?]*[ -\/]*[@-~](\x1B[=>]\r?)*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
show configuration
[?1h=
interfaces {[m
ethernet eth1 {[m
duplex auto[m
address 172.22.108.100/24[m
speed auto[m
smp_affinity auto[m
}[m
loopback lo {[m
}[m
}[m
system {[m
time-zone UTC[m
syslog {[m
}[m
config-management {[m
commit-revisions 20[m
}[m
host-name dm2500[m
[m
BLABLABLA
[K[?1l>admin@dm2500:~$
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)