$re = '/(\x1B7)?(\x9B|\x1B\[)[0-?]*[ -\/]*[@-~](\x1B[=>]\r?)*/';
$str = 'show configuration
[?1h=
interfaces {[m
ethernet eth1 {[m
duplex auto[m
address 172.22.108.100/24[m
speed auto[m
smp_affinity auto[m
}[m
loopback lo {[m
}[m
}[m
system {[m
time-zone UTC[m
syslog {[m
}[m
config-management {[m
commit-revisions 20[m
}[m
host-name dm2500[m
[m
BLABLABLA
[K[?1l>admin@dm2500:~$ ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);