using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\x1B7)?(\x9B|\x1B\[)[0-?]*[ -\/]*[@-~](\x1B[=>]\r?)*";
string input = @"show configuration
[?1h=
interfaces {[m
ethernet eth1 {[m
duplex auto[m
address 172.22.108.100/24[m
speed auto[m
smp_affinity auto[m
}[m
loopback lo {[m
}[m
}[m
system {[m
time-zone UTC[m
syslog {[m
}[m
config-management {[m
commit-revisions 20[m
}[m
host-name dm2500[m
[m
BLABLABLA
[K[?1l>admin@dm2500:~$ ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}