// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\x1B7)?(\x9B|\x1B\[)[0-?]*[ -\/]*[@-~](\x1B[=>]\r?)*").unwrap();
let string = "show configuration
[?1h=
interfaces {[m
ethernet eth1 {[m
duplex auto[m
address 172.22.108.100/24[m
speed auto[m
smp_affinity auto[m
}[m
loopback lo {[m
}[m
}[m
system {[m
time-zone UTC[m
syslog {[m
}[m
config-management {[m
commit-revisions 20[m
}[m
host-name dm2500[m
[m
BLABLABLA
[K[?1l>admin@dm2500:~$ ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}