import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\x1B7)?(\\x9B|\\x1B\\[)[0-?]*[ -\\/]*[@-~](\\x1B[=>]\\r?)*";
final String string = "show configuration\n"
+ "[?1h=\n"
+ "interfaces {[m\n"
+ " ethernet eth1 {[m\n"
+ " duplex auto[m\n"
+ " address 172.22.108.100/24[m\n"
+ " speed auto[m\n"
+ " smp_affinity auto[m\n"
+ " }[m\n"
+ " loopback lo {[m\n"
+ " }[m\n"
+ "}[m\n"
+ "system {[m\n"
+ " time-zone UTC[m\n"
+ " syslog {[m\n"
+ " }[m\n"
+ " config-management {[m\n"
+ " commit-revisions 20[m\n"
+ " }[m\n"
+ " host-name dm2500[m\n"
+ "[m\n"
+ "BLABLABLA\n"
+ "[K[?1l>admin@dm2500:~$ ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}