import Foundation
let pattern = #"\"?([^\""]*)\"? \"?([^\""]*)\"? (\d{2}) (\d{5}).(\d{2}) (\d{3}-\d{7})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""Mattias Asplund" 46 35000.00 070-6186120"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)