#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\"?([^\""]*)\"? \"?([^\""]*)\"? (\d{2}) (\d{5}).(\d{2}) (\d{3}-\d{7})"
Local $sString = ""Mattias Asplund" 46 35000.00 070-6186120"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)